import Foundation
let pattern = #"^ (\w*?): ((Number|String|Object|Array),?\n)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
props: {
book: Object,
progress: Object,
tableData: Array,
},
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #" $1: {\n type: $3,\n required: true\n },\n\n"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)