use strict;
my $str = '
props: {
book: Object,
progress: Object,
tableData: Array,
},';
my $regex = qr/^ (\w*?): ((Number|String|Object|Array),?\n)/mp;
my $subst = ' $1: {\\n type: $3,\\n required: true\\n },\\n\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";