package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([^\s]+)\s+((?1)\s+(?1))`)
var str = `Some example here for you`
var substitution = "\1 \2,"
fmt.Println(re.ReplaceAllString(str, substitution))
}