import re
regex = re.compile(r"^([^\s]+)\s+((?1)\s+(?1))", flags=re.MULTILINE)
test_str = "Some example here for you"
subst = "\\1 \\2,"
result = regex.sub(subst, test_str)
if result:
print(result)