import Foundation
let pattern = #"^([^\s]+)\s+((?1)\s+(?1))"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"Some example here for you"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1 \2,"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)