$re = '/^([^\s]+)\s+((?1)\s+(?1))/m';
$str = 'Some example here for you';
$subst = "\1 \2,";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;