use strict;
my $str = 'Some example here for you';
my $regex = qr/^([^\s]+)\s+((?1)\s+(?1))/mp;
my $subst = '\\1 \\2,';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";