re = /^([^\s]+)\s+((?1)\s+(?1))/m
str = 'Some example here for you'
subst = '\\1 \\2,'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result