use strict;
my $str = '/aaa/bbbb/ccccc.htm
/xxx/yyy.htm';
my $regex = qr`^\/[a-z]+\/[a-z]+.htm$`mp;
my $subst = '';
my $result = $str =~ s`$regex`$subst`rg;
print "The result of the substitution is' $result\n";