import Foundation
let pattern = #"^\/[a-z]+\/[a-z]+.htm$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
/aaa/bbbb/ccccc.htm
/xxx/yyy.htm
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)