re = /^\/[a-z]+\/[a-z]+.htm$/m
str = '/aaa/bbbb/ccccc.htm
/xxx/yyy.htm'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result