#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = " *\b\S*?undefined\S*\b"
Local $sString = "hello my number is 344undefined848 undefinedundefined undefinedcalling whistleundefined";"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)