using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @" *\b\S*?undefined\S*\b";
string substitution = @"";
string input = @"hello my number is 344undefined848 undefinedundefined undefinedcalling whistleundefined"";";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}