// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r" *\b\S*?undefined\S*\b").unwrap();
let string = "hello my number is 344undefined848 undefinedundefined undefinedcalling whistleundefined\";";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}