use strict;
my $str = 'hello my number is 344undefined848 undefinedundefined undefinedcalling whistleundefined";';
my $regex = qr/ *\b\S*?undefined\S*\b/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";