$re = '/ *\b\S*?undefined\S*\b/';
$str = 'hello my number is 344undefined848 undefinedundefined undefinedcalling whistleundefined";';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;