import re
regex = re.compile(r" *\b\S*?undefined\S*\b")
test_str = "hello my number is 344undefined848 undefinedundefined undefinedcalling whistleundefined\";"
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)