const regex = / *\b\S*?undefined\S*\b/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp(' *\\b\\S*?undefined\\S*\\b', 'g')
const str = `hello my number is 344undefined848 undefinedundefined undefinedcalling whistleundefined";`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);