import Foundation
let pattern = #" *\b\S*?undefined\S*\b"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"hello my number is 344undefined848 undefinedundefined undefinedcalling whistleundefined";"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)