re = / *\b\S*?undefined\S*\b/
str = 'hello my number is 344undefined848 undefinedundefined undefinedcalling whistleundefined";'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result