using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"url\((\'|\"")~[\w.\/\-]*(png|gif|jpg|jpeg|svg)[\w.\/]*(\'|\"")\);*\s*";
string input = @".FrontPage .fb {
background: url(""~fb-logo-blue.png""); }
background: url(""~/images/logos/fb-logo-blue.png""); }
background: url(""~fb-logo-blue.png"");}
background: url(""~fb-logo-blue.gif"");}
background: url(""~fb-logo-blue.jpg"");}
background: url(""~fb-logo-blue.jpeg"");}
background: url(""~fb-logo-blue.svg"");}
background:url(""~fb-logo-blue.png"");;}
background:url(""~fb-logo-blue.png"");color:red}
background:url(""~fb-logo-blue.png"")}
background:url(""~"")}
background:url(""fb-logo-blue.png"")}
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}