import Foundation
let pattern = #"url\((\'|\")~[\w.\/\-]*(png|gif|jpg|jpeg|svg)[\w.\/]*(\'|\")\);*\s*"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
.FrontPage .fb {
background: url("~fb-logo-blue.png"); }
background: url("~/images/logos/fb-logo-blue.png"); }
background: url("~fb-logo-blue.png");}
background: url("~fb-logo-blue.gif");}
background: url("~fb-logo-blue.jpg");}
background: url("~fb-logo-blue.jpeg");}
background: url("~fb-logo-blue.svg");}
background:url("~fb-logo-blue.png");;}
background:url("~fb-logo-blue.png");color:red}
background:url("~fb-logo-blue.png")}
background:url("~")}
background:url("fb-logo-blue.png")}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)