$re = '/url\((\'|\")~[\w.\/\-]*(png|gif|jpg|jpeg|svg)[\w.\/]*(\'|\")\);*\s*/';
$str = '.FrontPage .fb {
background: url("~fb-logo-blue.png"); }
background: url("~/images/logos/fb-logo-blue.png"); }
background: url("~fb-logo-blue.png");}
background: url("~fb-logo-blue.gif");}
background: url("~fb-logo-blue.jpg");}
background: url("~fb-logo-blue.jpeg");}
background: url("~fb-logo-blue.svg");}
background:url("~fb-logo-blue.png");;}
background:url("~fb-logo-blue.png");color:red}
background:url("~fb-logo-blue.png")}
background:url("~")}
background:url("fb-logo-blue.png")}
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);