import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "url\\((\\'|\\\")~[\\w.\\/\\-]*(png|gif|jpg|jpeg|svg)[\\w.\\/]*(\\'|\\\")\\);*\\s*";
final String string = ".FrontPage .fb {\n"
+ " background: url(\"~fb-logo-blue.png\"); }\n"
+ " background: url(\"~/images/logos/fb-logo-blue.png\"); }\n"
+ " background: url(\"~fb-logo-blue.png\");}\n"
+ " background: url(\"~fb-logo-blue.gif\");}\n"
+ " background: url(\"~fb-logo-blue.jpg\");}\n"
+ " background: url(\"~fb-logo-blue.jpeg\");}\n"
+ " background: url(\"~fb-logo-blue.svg\");}\n"
+ " background:url(\"~fb-logo-blue.png\");;}\n"
+ " background:url(\"~fb-logo-blue.png\");color:red}\n"
+ " background:url(\"~fb-logo-blue.png\")}\n"
+ " background:url(\"~\")}\n"
+ " background:url(\"fb-logo-blue.png\")}\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}