re = /url\((\'|\")~[\w.\/\-]*(png|gif|jpg|jpeg|svg)[\w.\/]*(\'|\")\);*\s*/
str = '.FrontPage .fb {
background: url("~fb-logo-blue.png"); }
background: url("~/images/logos/fb-logo-blue.png"); }
background: url("~fb-logo-blue.png");}
background: url("~fb-logo-blue.gif");}
background: url("~fb-logo-blue.jpg");}
background: url("~fb-logo-blue.jpeg");}
background: url("~fb-logo-blue.svg");}
background:url("~fb-logo-blue.png");;}
background:url("~fb-logo-blue.png");color:red}
background:url("~fb-logo-blue.png")}
background:url("~")}
background:url("fb-logo-blue.png")}
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end