# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"url\((\'|\")~[\w.\/\-]*(png|gif|jpg|jpeg|svg)[\w.\/]*(\'|\")\);*\s*"
test_str = (".FrontPage .fb {\n"
" background: url(\"~fb-logo-blue.png\"); }\n"
" background: url(\"~/images/logos/fb-logo-blue.png\"); }\n"
" background: url(\"~fb-logo-blue.png\");}\n"
" background: url(\"~fb-logo-blue.gif\");}\n"
" background: url(\"~fb-logo-blue.jpg\");}\n"
" background: url(\"~fb-logo-blue.jpeg\");}\n"
" background: url(\"~fb-logo-blue.svg\");}\n"
" background:url(\"~fb-logo-blue.png\");;}\n"
" background:url(\"~fb-logo-blue.png\");color:red}\n"
" background:url(\"~fb-logo-blue.png\")}\n"
" background:url(\"~\")}\n"
" background:url(\"fb-logo-blue.png\")}\n")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.