// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"url\((\'|\")~[\w.\/\-]*(png|gif|jpg|jpeg|svg)[\w.\/]*(\'|\")\);*\s*"#).unwrap();
let string = ".FrontPage .fb {
background: url(\"~fb-logo-blue.png\"); }
background: url(\"~/images/logos/fb-logo-blue.png\"); }
background: url(\"~fb-logo-blue.png\");}
background: url(\"~fb-logo-blue.gif\");}
background: url(\"~fb-logo-blue.jpg\");}
background: url(\"~fb-logo-blue.jpeg\");}
background: url(\"~fb-logo-blue.svg\");}
background:url(\"~fb-logo-blue.png\");;}
background:url(\"~fb-logo-blue.png\");color:red}
background:url(\"~fb-logo-blue.png\")}
background:url(\"~\")}
background:url(\"fb-logo-blue.png\")}
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}