use strict;
my $str = '.FrontPage .fb {
background: url("~fb-logo-blue.png"); }
background: url("~/images/logos/fb-logo-blue.png"); }
background: url("~fb-logo-blue.png");}
background: url("~fb-logo-blue.gif");}
background: url("~fb-logo-blue.jpg");}
background: url("~fb-logo-blue.jpeg");}
background: url("~fb-logo-blue.svg");}
background:url("~fb-logo-blue.png");;}
background:url("~fb-logo-blue.png");color:red}
background:url("~fb-logo-blue.png")}
background:url("~")}
background:url("fb-logo-blue.png")}
';
my $regex = qr/url\((\'|\")~[\w.\/\-]*(png|gif|jpg|jpeg|svg)[\w.\/]*(\'|\")\);*\s*/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}