const regex = /url\((\'|\")~[\w.\/\-]*(png|gif|jpg|jpeg|svg)[\w.\/]*(\'|\")\);*\s*/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('url\\((\\\'|\\")~[\\w.\\\/\\-]*(png|gif|jpg|jpeg|svg)[\\w.\\\/]*(\\\'|\\")\\);*\\s*', 'g')
const str = `.FrontPage .fb {
background: url("~fb-logo-blue.png"); }
background: url("~/images/logos/fb-logo-blue.png"); }
background: url("~fb-logo-blue.png");}
background: url("~fb-logo-blue.gif");}
background: url("~fb-logo-blue.jpg");}
background: url("~fb-logo-blue.jpeg");}
background: url("~fb-logo-blue.svg");}
background:url("~fb-logo-blue.png");;}
background:url("~fb-logo-blue.png");color:red}
background:url("~fb-logo-blue.png")}
background:url("~")}
background:url("fb-logo-blue.png")}
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}