#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "Sub SubName[\s\S]*?End Sub"
Local $sString = "Sub SubName" & @CRLF & _
" 'sub implementation having multi line statements. It may have comments also." & @CRLF & _
"End Sub" & @CRLF & _
"" & @CRLF & _
"Sub SubName" & @CRLF & _
" 'sub implementation having multi line statements. It may have comments also." & @CRLF & _
"End Sub"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")