const regex = /Sub SubName[\s\S]*?End Sub/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('Sub SubName[\\s\\S]*?End Sub', '')
const str = `Sub SubName
'sub implementation having multi line statements. It may have comments also.
End Sub
Sub SubName
'sub implementation having multi line statements. It may have comments also.
End Sub`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}