$re = '/Sub SubName[\s\S]*?End Sub/';
$str = 'Sub SubName
\'sub implementation having multi line statements. It may have comments also.
End Sub
Sub SubName
\'sub implementation having multi line statements. It may have comments also.
End Sub';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);