import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "Sub SubName[\\s\\S]*?End Sub";
final String string = "Sub SubName\n"
+ " 'sub implementation having multi line statements. It may have comments also.\n"
+ "End Sub\n\n"
+ "Sub SubName\n"
+ " 'sub implementation having multi line statements. It may have comments also.\n"
+ "End Sub";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}