import Foundation
let pattern = #"Sub SubName[\s\S]*?End Sub"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Sub SubName
'sub implementation having multi line statements. It may have comments also.
End Sub
Sub SubName
'sub implementation having multi line statements. It may have comments also.
End Sub
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}