re = /Sub SubName[\s\S]*?End Sub/
str = 'Sub SubName
\'sub implementation having multi line statements. It may have comments also.
End Sub
Sub SubName
\'sub implementation having multi line statements. It may have comments also.
End Sub'
# Print the match result
str.match(re) do |match|
puts match.to_s
end