// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"Sub SubName[\s\S]*?End Sub").unwrap();
let string = "Sub SubName
'sub implementation having multi line statements. It may have comments also.
End Sub
Sub SubName
'sub implementation having multi line statements. It may have comments also.
End Sub";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}