package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`Sub SubName[\s\S]*?End Sub`)
var str = `Sub SubName
'sub implementation having multi line statements. It may have comments also.
End Sub
Sub SubName
'sub implementation having multi line statements. It may have comments also.
End Sub`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}