using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Sub SubName[\s\S]*?End Sub";
string input = @"Sub SubName
'sub implementation having multi line statements. It may have comments also.
End Sub
Sub SubName
'sub implementation having multi line statements. It may have comments also.
End Sub";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}