#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "<loc>(http:\/\/.+)<\/loc>"
Local $sString = "import urllib2 as ur" & @CRLF & _
"import re" & @CRLF & _
"" & @CRLF & _
"f = ur.urlopen(u'http://bodyshopdirectory.co.uk/main_sitemap.xml')" & @CRLF & _
"res = f.readlines()" & @CRLF & _
"for d in res:" & @CRLF & _
" data = re.findall('<loc>(http:\/\/.+)<\/loc>',d)" & @CRLF & _
" for i in data:" & @CRLF & _
" print i"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")