import re
regex = re.compile(r"<loc>(http:\/\/.+)<\/loc>")
test_str = ("import urllib2 as ur\n"
"import re\n\n"
"f = ur.urlopen(u'http://bodyshopdirectory.co.uk/main_sitemap.xml')\n"
"res = f.readlines()\n"
"for d in res:\n"
" data = re.findall('<loc>(http:\\/\\/.+)<\\/loc>',d)\n"
" for i in data:\n"
" print i")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")