$re = '/<loc>(http:\/\/.+)<\/loc>/';
$str = 'import urllib2 as ur
import re
f = ur.urlopen(u\'http://bodyshopdirectory.co.uk/main_sitemap.xml\')
res = f.readlines()
for d in res:
data = re.findall(\'<loc>(http:\\/\\/.+)<\\/loc>\',d)
for i in data:
print i';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);