use strict;
my $str = 'import urllib2 as ur
import re
f = ur.urlopen(u\'http://bodyshopdirectory.co.uk/main_sitemap.xml\')
res = f.readlines()
for d in res:
data = re.findall(\'<loc>(http:\\/\\/.+)<\\/loc>\',d)
for i in data:
print i';
my $regex = qr/<loc>(http:\/\/.+)<\/loc>/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}