package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<loc>(http:\/\/.+)<\/loc>`)
var str = `import urllib2 as ur
import re
f = ur.urlopen(u'http://bodyshopdirectory.co.uk/main_sitemap.xml')
res = f.readlines()
for d in res:
data = re.findall('<loc>(http:\/\/.+)<\/loc>',d)
for i in data:
print i`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}