using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<loc>(http:\/\/.+)<\/loc>";
string input = @"import urllib2 as ur
import re
f = ur.urlopen(u'http://bodyshopdirectory.co.uk/main_sitemap.xml')
res = f.readlines()
for d in res:
data = re.findall('<loc>(http:\/\/.+)<\/loc>',d)
for i in data:
print i";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}