import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<loc>(http:\\/\\/.+)<\\/loc>";
final String string = "import urllib2 as ur\n"
+ "import re\n\n"
+ "f = ur.urlopen(u'http://bodyshopdirectory.co.uk/main_sitemap.xml')\n"
+ "res = f.readlines()\n"
+ "for d in res:\n"
+ " data = re.findall('<loc>(http:\\/\\/.+)<\\/loc>',d)\n"
+ " for i in data:\n"
+ " print i";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}