// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"<loc>(http:\/\/.+)<\/loc>").unwrap();
let string = "import urllib2 as ur
import re
f = ur.urlopen(u'http://bodyshopdirectory.co.uk/main_sitemap.xml')
res = f.readlines()
for d in res:
data = re.findall('<loc>(http:\\/\\/.+)<\\/loc>',d)
for i in data:
print i";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}