using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\[bold\]?)(.*?)(\[\/bold\]?)";
string substitution = @"<CharacterStyleRange FillColor=""> <Properties> <AppliedFont type=""string"">$2</AppliedFont> </Properties> <Content>Hallo</Content> </CharacterStyleRange>";
string input = @"Hallo [bold]ik[/bold] ben een zin [bold]met bold[/bold]";
RegexOptions options = RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}