import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\[bold\\]?)(.*?)(\\[\\/bold\\]?)";
final String string = "Hallo [bold]ik[/bold] ben een zin [bold]met bold[/bold]";
final String subst = "<CharacterStyleRange FillColor=\"\"> <Properties> <AppliedFont type=\"string\">$2</AppliedFont> </Properties> <Content>Hallo</Content> </CharacterStyleRange>";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}