package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)(\[bold\]?)(.*?)(\[\/bold\]?)`)
var str = `Hallo [bold]ik[/bold] ben een zin [bold]met bold[/bold]`
var substitution = "<CharacterStyleRange FillColor=""> <Properties> <AppliedFont type="string">$2</AppliedFont> </Properties> <Content>Hallo</Content> </CharacterStyleRange>"
fmt.Println(re.ReplaceAllString(str, substitution))
}