import re
regex = re.compile(r"(\[bold\]?)(.*?)(\[\/bold\]?)", flags=re.IGNORECASE)
test_str = "Hallo [bold]ik[/bold] ben een zin [bold]met bold[/bold]"
subst = "<CharacterStyleRange FillColor=\"\"> <Properties> <AppliedFont type=\"string\">$2</AppliedFont> </Properties> <Content>Hallo</Content> </CharacterStyleRange>"
result = regex.sub(subst, test_str)
if result:
print(result)